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Error: You are not authorized... You must sign-in using your Microsoft 365 credentials

Overview

When attempting to access your Dynamics 365 Business Central data using either Jet Reports or Jet Reports Financials, a message is displayed:

You are not authorized to access this data source. You must sign-in using your Microsoft 365 credentials for authorization.

Cause:

This error message is caused when the password for your Microsoft 365 account has changed since you established your data source settings.

Resolution Process

  1. Using Jet Reports

    Access the Data Source Settings for your Business Central data source. The Data Source Settings window is dispalyed.

    Select Authentication > Log out, and then click Log in.

    When prompted, log in to your Microsoft 365 account.

  2. Using Jet Reports Financials

    1. Close Excel completely (ensure that no EXCEL.EXE processes are running in Windows Task Manager)
    2. Open Windows Explorer, type %appdata% in the address bar and press enter roaming1.png This will bring you to your roaming profile folder C:\Users\ username \AppData\Roaming\ Rename the Jet Reports folder to Jet Reports OLD
    3. Close Windows Explorer
    4. Open Excel
    5. Sign into your Business Central account when prompted
    6. Test to ensure that the issue is resolved

Published:

Error: You are not authorized... You must sign-in using your Microsoft 365 credentials

Overview

When attempting to access your Dynamics 365 Business Central data using either Jet Reports or Jet Reports Financials, a message is displayed:

You are not authorized to access this data source. You must sign-in using your Microsoft 365 credentials for authorization.

Cause:

This error message is caused when the password for your Microsoft 365 account has changed since you established your data source settings.

Resolution Process

  1. Using Jet Reports

    Access the Data Source Settings for your Business Central data source. The Data Source Settings window is dispalyed.

    Select Authentication > Log out, and then click Log in.

    When prompted, log in to your Microsoft 365 account.

  2. Using Jet Reports Financials

    1. Close Excel completely (ensure that no EXCEL.EXE processes are running in Windows Task Manager)
    2. Open Windows Explorer, type %appdata% in the address bar and press enter roaming1.png This will bring you to your roaming profile folder C:\Users\ username \AppData\Roaming\ Rename the Jet Reports folder to Jet Reports OLD
    3. Close Windows Explorer
    4. Open Excel
    5. Sign into your Business Central account when prompted
    6. Test to ensure that the issue is resolved

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