Skip to main content

An exception of type System.Data.Entity..

Issue

When deleting a user in the Jet Administration Console the following error is displayed:

deleteuser.png

Complete text of error message is:

An exception of type System.Data.Entity.Infrastructure.DbUpdateException, EntityFramework was thrown. An error occurred while updating the entries. See the inner exception for details.

Cause

The user being deleted from the Jet Administration Console is still the 'Owner' of a report in Jet Hub

Resolution

  1. Sign into Jet Hub as an 'Administrator'.
  2. Review the Owner column and determine which report(s) is/are owned by that user.

    owner2.png

    If the Owner column is not being displayed, click the three dots to the right of the name of any column, select Columns , and check the box for Owner.

    columns.png

  3. Right-click the report and select Change Owner.

  4. Change the Owner to a different user.
  5. Repeat this process for all reports where the user you are attempting to delete from the Jet Administration Console is the listed 'Owner'.
  6. Once the user is no longer an 'Owner' of any reports, you can delete them from the Jet Administration Console.

Was this article helpful?

We're sorry to hear that.