Error: Either the user does not have permission to alter the object, or the object does not exist
Symptoms
When working within the Jet Data Manager (or within SQL Server Analysis Services), the following error message is displayed:
" Either the '{user name}' user does not have permission to alter the '{name of object}' object, or the object does not exist."
Cause
The user (under whose credentials the Jet Data Manager is running) does not have Admin permissions. The Jet Data Manager uses SQL Server Analysis Services, which requires that the user have Admin permissions.
Resolution
Generally speaking, this is a permissions error and the user account that the JDM is running as will need to have Admin privileges granted.
However, what if the only account that has SQL Server Admin rights was the initial installer and they're no longer available? In situations like this, it is much more reasonable and expedient to follow the process detailed below and grant those permissions locally, rather than uninstall/reinstall the SQL Server and/or wait for that person to be available to grant such permissions.
- Launch Services.msc as an admin account. This can be found here: C:\Windows\System32\Services.msc.
- Scroll down to SQL Server Analysis Services (NAMED_INSTANCE) Right-click the service name and select Stop
- Right-click the service name again and select Properties
-
On the
Log On
tab, copy the value that is currently set in the
This account:
box and paste this into a notepad file for temporary storage.
- Typically, this will be NT Service\MSSQLServerOLAPService.
- Once copied, change the This account: box to reflect the user you would like to grant Admin privileges to and fill in the corresponding password fields.
- Once the fields are complete, click Apply , then OK
-
Right-click the service once more, and select
Start
- At this point, we have changed the default account that Analysis Services will run as to an account that we can make changes with.
-
Now, open your
SQL Server Management Studio
(SSMS) program and connect to
Analysis Services
- If the account you are granting 'Admin' privileges differs from the account you're logged in as, you will need to run SSMS as the account you assigned in Step 5.
- Once connected, in the Object Explorer tree (on the left) right-click the server name and select Properties.
- Click Security from the list on the left pane and then choose Add
-
Choose the correct location to find your new 'Admin' account, type in the name, and then click
Check Names
- Once you've identified the correct account, simply select it, click OK , and then click OK once more.
- We've now added this login as an Analysis Services administrator account.
- The last step is to reset the default account that the 'Analysis Services' service will run as, so open up your Services.msc window again.
- Locate the SQL Server Analysis Services (NAMED_INSTANCE) service again, right-click it and select Stop
- Right-click the service name again and select Properties
-
On the
Log On
tab, paste the value that you previously copied into a notepad into the
This account:
box.
- Delete the **** entries within the two password fields.
- Once the fields are complete, click Apply , then OK.
- Right-click the service once more, and select Start
What this process does is set your primary account as a default Analysis Services admin account. Upon doing this, you can then physically add your primary account to the Analysis Services security, correctly. Once your primary account is setup within the security protocols, you simply rollback the default admin account to the NT SERVICE default and restart the service.