Empty filter not allowed when filtering by an email address
Issue
When using Microsoft Dynamics NAV and filtering a Jet function based on an email address, the cell displays #VALUE! and the message "Empty filter not allowed" is displayed.
Cause
Email addresses contain the @ symbol.
Dynamics NAV reserves the @ symbol as a toggle between case (in)sensitivity.
It is not possible to filter on a field that contains an @ symbol when querying Dynamics NAV.