Error: Our report execution has encountered inconsistent data
Overview
When attempting to run a report against a Dynamics 365 Business Central public cloud data using Jet Reports, the following error is received:
Our report execution has encountered inconsistent data, which indicates that data may have changed while the report was running. We recommend re-running the report to ensure the accuracy of the data.
Cause
During the report execution, the underlying data from the queried tables might have changed. For example, a record in the dataset may have been added or removed. Beginning with Jet Reports 24.1.1 detection of these data changes might occur.
Despite potential changes in the underlying data, the accuracy of the data remains intact, and it may not be necessary to re-run the report.
Solution
To resolve the issue, perform any one of the following:
Re-run the report.
Disable the Table Cache Optimization and re-run the report.
If disabling Cache Tables Optimization does not resolve the error, please contact our support team.