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Error - The underlying connection was closed: An unexpected error occurred on a send

Overview

When connecting to a Dynamics Business Central SaaS data source (public cloud), the following error is received:

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Complete text of error message is:

The underlying connection was closed: An unexpected error occurred on a send.

Cause

Starting at the beginning of June 2020, Microsoft started rolling out enforced TLS 1.2 for any connections to BC SaaS web services. The error above is suggesting that Jet is unable to make a connection over TLS 1.2.

Resolution Process

  1. The first version of Jet Reports to support TLS 1.2 for Business Central Public Cloud data sources was 20.4.1. Please ensure that your version of Jet is at least this version and upgrade if lower. The latest version can be downloaded from here. You can check your version in Help > About on the Jet Ribbon.

  2. TLS 1.2 is not enabled on the machine where Jet Reports is installed - enable TLS 1.2 on this machine.

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