Internal Error 1005 in Module 19
Overview
When attempting to connect to a data source for Dynamics NAV 2009R2 or earlier, the following error is displayed:
Complete text of error message is:
Internal error 1005 in module 19.
Cause
This message indicates that the field being queried was not found in the database.
Note: Errors in Module 19 are C/Front errors. They can be looked up in a supporting C/Front file called “DBERROR.txt” which resides in the C/Front program files folder.
C/Front is the NAV utility which handles communications between NAV and other applications.
Error 1005 corresponds to the following message: “Err_DB_UnknownFieldNo” which means that the problematic query is unable to find the field in the specified database.
Typically, C/Front is unable to find the field in question due to incorrect language configuration in the Jet Excel Add-In.
Resolution
To resolve this problem, you’ll need to export your Dynamics NAV Language Module then specify both the Language Module Folder and the corresponding Language in the Data Source Settings in the Jet Excel Add-In.