Error: We cannot currently authenticate you against your Dynamics 365 Business Central tenant
Overview
When attempting to create a new budget, upload a report, or run a report in the Jet Hub with a Dynamics 365 Business Central data source, an error message is displayed:
Complete text of error message is
We cannot currently authenticate you against your Dynamics 365 Business Central tenant.
Cause
Your Microsoft 365 credentials are not currently set for your Business Central data data source
Resolution Process
Cancel out of the dialog in the Jet Hub.
Start Excel with the Jet Reports add-in installed using the same profile that was logged into the Jet Hub.
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Go to your Dynamics 365 Business Central data source settings.
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On the Authentication tab, you'll see that a user is not logged in . Click the Log in button.
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When prompted, select the Microsoft 365 account you want to use to connect to your data
and enter the password associated with that account.
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On the Authentication tab, you should now see that the selected account is listed as the User.
Return to the Jet Hub and complete your task.