Error: Value Cannot Be Null
Overview
When trying to connect to your Business Central data source, you see this message:
Accounts could not be loaded. The following error was reported:
Value cannot be null. Parameter name: type
Cause
Changes made by Microsoft to Business Central can affect how internal codeunits are named.
Resolution Process
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Sign in to your Business Central account and search for Web Services.
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Find the Jet Data Source reference and remove it from the list.
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Create a new Web Service for the Jet Data Source code unit and name it JetDataSource (no spaces).
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For the new JetDataSource codeunit, ensure that the box for PUBLISH is checked and that the box for ALL TENANTS is not checked.
You are now done working in Business Central.
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Open Windows File Explorer.
Ensure that Microsoft Excel is closed .
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Navigate to the Jet Reports Settings folder: %Appdata%\Jet Reports and open the file Data Sources.xml for editing.
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Find the <setting> name WebServiceCodeUnit and change the <value> to JetDataSource.
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Save the file.
You should now be able to restart Jet Reports Financials.
Open Excel and verify that Jet Reports Financials can now properly connect to Business Central.
Every Jet Reports Financials user will need to edit their Data Sources.xml file